cc/td/doc/product/core/cis7600/ios121_8
hometocprevnextglossaryfeedbacksearchhelp
PDF

Table of Contents

Configuring EtherChannel

Configuring EtherChannel

This chapter describes how to configure EtherChannel on the Cisco 7600 series Internet Router Layer 2 or Layer 3 LAN ports.


Note   For complete syntax and usage information for the commands used in this chapter, refer to the Cisco 7600 Series Internet Router IOS Command Reference publication

This chapter consists of these sections:

Understanding How EtherChannel Works

These sections describe how EtherChannel works:

EtherChannel Overview

EtherChannel bundles individual Ethernet links into a single logical link that provides the aggregate bandwidth of up to eight physical links.

A Cisco 7600 series Internet Router supports a maximum of 64 EtherChannels (256 with Release 12.1(2)E and earlier). You can form an EtherChannel with up to eight compatibly configured LAN ports on any module in a Cisco 7600 series Internet Router. All LAN ports in each EtherChannel must be the same speed and must all be configured as either Layer 2 or Layer 3 LAN ports.


Note   The network device to which a Cisco 7600 series Internet Router is connected may impose its own limits on the number of ports in an EtherChannel.

If a segment within an EtherChannel fails, traffic previously carried over the failed link switches to the remaining segments within the EtherChannel. A trap is sent upon a failure identifying the Internet Router, the EtherChannel, and the failed link. Inbound broadcast and multicast packets on one segment in an EtherChannel are blocked from returning on any other segment of the EtherChannel.

Understanding Port Channel Interfaces

Each EtherChannel has a numbered port channel interface. Release 12.1(5)E and later supports a maximum of 64 port channel interfaces, numbered from 1 to 256.


Note   Releases 12.1(4)E1, 12.1(3a)E4, and 12.1(3a)E3 support a maximum of 64 port channel interfaces, numbered from 1 to 64. Release 12.1(2)E and earlier support a maximum of 256 port channel interfaces, numbered from 1 to 256.

Configuration that you apply to the port channel interface affects all LAN ports assigned to the port channel interface.

After you configure an EtherChannel, configuration that you apply to the port channel interface affects the EtherChannel; configuration that you apply to the LAN ports affects only the LAN port where you apply the configuration. To change the parameters of all ports in an EtherChannel, apply configuration commands to the port channel interface; for example, Spanning Tree Protocol commands or commands to configure a Layer 2 EtherChannel as a trunk.

Understanding the Port Aggregation Protocol

The Port Aggregation Protocol (PAgP) supports the automatic creation of EtherChannels by exchanging PAgP packets between LAN ports. PAgP packets are exchanged only between ports in auto and desirable modes. LAN ports configured in the on mode do not exchange PAgP packets.

The protocol learns the capabilities of LAN port groups dynamically and informs the other LAN ports. Once PAgP identifies correctly matched Ethernet links, it facilitates grouping the links into an EtherChannel. The EtherChannel is then added to the spanning tree as a single bridge port.

EtherChannel includes three user-configurable modes: on, auto, and desirable (see Table 10-1). Only auto and desirable are PAgP modes.


Table 10-1: EtherChannel Modes
Mode Description

on

Mode that forces the LAN port to channel without PAgP. In the on mode, a usable EtherChannel exists only when a LAN port group in the on mode is connected to another LAN port group in the on mode.

auto

PAgP mode that places a LAN port into a passive negotiating state, in which the port responds to PAgP packets it receives but does not initiate PAgP packet negotiation. (Default)

desirable

PAgP mode that places a LAN port into an active negotiating state, in which the port initiates negotiations with other LAN ports by sending PAgP packets.

Both the auto and desirable modes allow LAN ports to negotiate with partner LAN ports to determine if they can form an EtherChannel, based on criteria such as port speed and, for Layer 2 EtherChannels, trunking state and VLAN numbers.

LAN ports can form an EtherChannel when they are in different PAgP modes as long as the modes are compatible. For example:

Understanding Load Balancing

EtherChannel balances traffic load across the links in a channel by reducing part of the binary pattern formed from the addresses in the frame to a numerical value that selects one of the links in the channel.

EtherChannel load balancing can use MAC addresses, IP addresses, or Layer 4 port numbers with a PFC2; either source or destination or both source and destination. The selected mode applies to all EtherChannels configured on the Internet Router.

Use the option that provides the greatest variety in your configuration. For example, if the traffic on a channel is going only to a single MAC address, using the destination MAC address always chooses the same link in the channel; using source addresses or IP addresses might result in better load balancing.

EtherChannel Configuration Guidelines and Restrictions

If improperly configured, some EtherChannel interfaces are disabled automatically to avoid network loops and other problems. Follow these guidelines and restrictions to avoid configuration problems:

Configuring EtherChannel

These sections describe how to configure EtherChannel:

Configuring Layer 3 EtherChannels

To configure Layer 3 EtherChannels, create the port channel logical interface and then put the Layer 3 LAN ports into the port channel.

These sections describe Layer 3 EtherChannel configuration:

Creating Port Channel Logical Interfaces


Note   To move an IP address from a LAN port to an EtherChannel, you must delete the IP address from the LAN port before configuring it on the port channel interface.

To create a port channel interface for a Layer 3 EtherChannel, perform this task:

Command Purpose

Step 1 

Router(config)# interface port-channel number 

Creates the port channel interface.

Router(config)# no interface port-channel number 

Deletes the port channel interface.

Step 2 

Router(config-if)# ip address ip_address mask 

Assigns an IP address and subnet mask to the EtherChannel.

Step 3 

Router(config-if)# end 

Exits configuration mode.

Step 4 

Router# show running-config interface 
port-channel number 

Verifies the configuration.

When creating the port channel interface, the group number can be one of the following:

This example shows how to create port channel interface 1:

Router# configure terminal 
Router(config)# interface port-channel 1 
Router(config-if)# ip address 172.32.52.10 255.255.255.0 
Router(config-if)# end 
 

This example shows how to verify the configuration of port channel interface 1:

Router# show running-config interface port-channel 1 
Building configuration...
 
Current configuration:
!
interface Port-channel1
 ip address 172.32.52.10 255.255.255.0
 no ip directed-broadcast
end
 
Router#

Configuring Layer 3 LAN Interfaces as a Layer 3 EtherChannel

To configure Layer 3 LAN ports as a Layer 3 EtherChannel, perform this task for each Layer 3 LAN port:

Command Purpose

Step 1 

Router(config)# interface type1 slot/port 

Selects a LAN port to configure.

Step 2 

Router(config-if)# no ip address 

Ensures that there is no IP address assigned to the LAN port.

Step 3 

Router(config-if)# channel-group number mode {auto | 
desirable | on} 

Configures the LAN port in a port channel and specify the PAgP mode.

Router(config-if)# no channel-group 

Removes the LAN port from the port channel.

Step 4 

Router(config-if)# end 

Exits configuration mode.

Step 5 

Router# show running-config interface port-channel 
number 
Router# show running-config interface 
type
1 slot/port 
Router# show interfaces 
type
1 slot/port etherchannel 
Router# show etherchannel 1 port-channel 

Verifies the configuration.

1type = ethernet, fastethernet, gigabitethernet, or tengigabitethernet

This example shows how to configure Fast Ethernet ports 5/4 and 5/5 into port channel 1 with PAgP mode desirable:

Router# configure terminal 
Router(config)# interface range fastethernet 5/4 -5 
Router(config-if)# no ip address 
Router(config-if)# channel-group 1 mode 
desirable 
Router(config-if)# end 

Note   See the "Configuring a Range of Interfaces" section for information about the range keyword.

This example shows how to verify the configuration of Fast Ethernet port 5/4:

Router# show running-config interface fastethernet 5/4 
Building configuration...
 
Current configuration:
!
interface FastEthernet5/4
 no ip address
 no ip directed-broadcast
 channel-group 1 mode auto
end
 
Router# show interfaces fastethernet 5/4 etherchannel 
Port state    = EC-Enbld Up In-Bndl Usr-Config
Channel group = 1           Mode = Desirable     Gcchange = 0
Port-channel  = Po1         GC   = 0x00010001    Psudo-agport = Po1
Port indx     = 0           Load = 0x55
 
Flags:  S - Device is sending Slow hello.  C - Device is in Consistent state.
        A - Device is in Auto mode.        P - Device learns on physical port.
Timers: H - Hello timer is running.        Q - Quit timer is running.
        S - Switching timer is running.    I - Interface timer is running.
 
Local information:
                                Hello    Partner  PAgP     Learning  Group
Port      Flags State   Timers  Interval Count   Priority   Method  Ifindex
Fa5/4     SC    U6/S7           30s      1        128        Any      55
 
Partner's information:
 
          Partner              Partner          Partner         Partner Group
Port      Name                 Device ID        Port       Age  Flags   Cap.
Fa5/4     JAB031301            0050.0f10.230c   2/45         1s SAC     2D
 
Age of the port in the current state: 00h:54m:52s
 
Router# 
 

This example shows how to verify the configuration of port channel interface 1 after the ports have been configured:

Router# show etherchannel 1 port-channel 
                Port-channels in the group:
                ----------------------
Port-channel: Po1
------------
 
Age of the Port-channel   = 01h:56m:20s
Logical slot/port   = 10/1           Number of ports in agport = 2
GC                  = 0x00010001      HotStandBy port = null
Passive port list   = Fa5/4 Fa5/5
Port state          = Port-channel L3-Ag Ag-Inuse
 
Ports in the Port-channel:
 
Index   Load   Port
-------------------
  0     55      Fa5/4
  1     AA      Fa5/5
 
Time since last port bundled:    01h:55m:44s    Fa5/5
 
Router#

Configuring Layer 2 EtherChannels

To configure Layer 2 EtherChannels, configure the LAN ports with the channel-group command, which creates the port channel logical interface.


Note   Cisco IOS creates port channel interfaces for Layer 2 EtherChannels when you configure Layer 2 LAN ports with the channel-group command. You cannot put Layer 2 LAN ports into a manually created port channel interface.


Note   For Cisco IOS to create port channel interfaces for Layer 2 EtherChannels, the Layer 2 LAN ports must be connected and functioning.

To configure Layer 2 LAN ports as a Layer 2 EtherChannel, perform this task for each LAN port:

Command Purpose

Step 1 

Router(config)# interface type1 slot/port 

Selects a LAN port to configure.

Step 2 

Router(config-if)# channel-group number mode 
{auto | desirable | on} 

Configures the LAN port in a port channel and specify the PAgP mode.

Router(config-if)# no channel-group 

Removes the LAN port from the channel group.

Step 3 

Router(config-if)# end 

Exits configuration mode.

Step 4 

Router# show running-config interface 
type1 slot/port 
 
Router# show interfaces 
type1 slot/port etherchannel 

Verifies the configuration.

1type = ethernet, fastethernet, gigabitethernet, or tengigabitethernet

This example shows how to configure Fast Ethernet ports 5/6 and 5/7 into port channel 2 with PAgP mode desirable:

Router# configure terminal 
Router(config)# interface range fastethernet 5/6 -7 
Router(config-if)# channel-group 2 mode 
desirable 
Router(config-if)# end 

Note   See the "Configuring a Range of Interfaces" section for information about the range keyword.

This example shows how to verify the configuration of port channel interface 2:

Router# show running-config interface port-channel 2 
Building configuration...
 
Current configuration:
!
interface Port-channel2
 no ip address
 switchport
 switchport access vlan 10
 switchport mode access
end
 
Router# 
 

This example shows how to verify the configuration of Fast Ethernet port 5/6:

Router# show running-config interface fastethernet 5/6 
Building configuration...
 
Current configuration:
!
interface FastEthernet5/6
 no ip address
 switchport
 switchport access vlan 10
 switchport mode access
 channel-group 2 mode desirable
end
 
Router# show interfaces fastethernet 5/6 etherchannel 
Port state    = EC-Enbld Up In-Bndl Usr-Config
Channel group = 2           Mode = Desirable     Gcchange = 0
Port-channel  = Po2         GC   = 0x00020001
Port indx     = 1           Load = 0x55
 
Flags:  S - Device is sending Slow hello.  C - Device is in Consistent state.
        A - Device is in Auto mode.        P - Device learns on physical port.
Timers: H - Hello timer is running.        Q - Quit timer is running.
        S - Switching timer is running.    I - Interface timer is running.
 
Local information:
                                Hello    Partner  PAgP     Learning  Group
Port      Flags State   Timers  Interval Count   Priority   Method  Ifindex
Fa5/6     SC    U6/S7           30s      1        128        Any      56
 
Partner's information:
 
          Partner              Partner          Partner         Partner Group
Port      Name                 Device ID        Port       Age  Flags   Cap.
Fa5/6     JAB031301            0050.0f10.230c   2/47        18s SAC     2F
 
Age of the port in the current state: 00h:10m:57s
 

This example shows how to verify the configuration of port channel interface 2 after the LAN ports have been configured:

Router# show etherchannel 2 port-channel 
                Port-channels in the group:
                ----------------------
 
Port-channel: Po2
------------
 
Age of the Port-channel   = 00h:23m:33s
Logical slot/port   = 10/2           Number of ports in agport = 2
GC                  = 0x00020001      HotStandBy port = null
Port state          = Port-channel Ag-Inuse
 
Ports in the Port-channel:
 
Index   Load   Port
-------------------
  1     55      Fa5/6
  0     AA      Fa5/7
 
Time since last port bundled:    00h:23m:33s    Fa5/6
 
Router# 

Configuring EtherChannel Load Balancing

To configure EtherChannel load balancing, perform this task:

Command Purpose

Step 1 

Router(config)# port-channel load-balance 
{src-mac | dst-mac | src-dst-mac | src-ip | 
dst-ip | src-dst-ip | src-port | dst-port | 
src-dst-port}

Configures EtherChannel load balancing.

Router(config)# no port-channel load-balance 

Reverts to default EtherChannel load balancing.

Step 2 

Router(config)# end 

Exits configuration mode.

Step 3 

Router# show etherchannel load-balance 

Verifies the configuration.

The load-balancing keywords are as follows:

This example shows how to configure EtherChannel to use source and destination IP addresses:

Router# configure terminal 
Router(config)# port-channel load-balance 
src-dst-ip 
Router(config)# end 
Router(config)# 
 

This example shows how to verify the configuration:

Router# show etherchannel load-balance 
Source XOR Destination IP address
Router# 


hometocprevnextglossaryfeedbacksearchhelp
Posted: Wed Aug 28 23:50:02 PDT 2002
All contents are Copyright © 1992--2002 Cisco Systems, Inc. All rights reserved.
Important Notices and Privacy Statement.