cc/td/doc/product/access/acs_serv/as5800/sw_conf
hometocprevnextglossaryfeedbacksearchhelp
PDF

Table of Contents

NFAS with D Channel Backup on the Cisco AS5800 and Cisco AS5850

NFAS with D Channel Backup on the Cisco AS5800 and Cisco AS5850

Feature History

Release Modification

12.1(5)XM

This feature was introduced.

12.2(2)XB1

This feature was implemented on the Cisco AS5850 platform.

12.2(11)T

This feature was integrated into Cisco IOS Release 12.2(11)T and support was added for the Cisco AS5850 platform.

This document includes the following sections:

Feature Overview

The DMS100 and NI2 switch types have been added to the existing Non-Facility Associated Signaling (NFAS) with D Channel Backup feature.

ISDN NFAS allows a single D channel to control multiple PRI interfaces. A backup D channel can be configured for use when the primary NFAS D channel fails.

Once the channelized T1 controllers are configured for ISDN PRI, only the NFAS primary D channel must be configured; its configuration is distributed to all the members of the associated NFAS group.


Note   The controller configured with backup D channel will lose 1 B channel.

Benefits

Use of a single D channel to control up to 10 PRI interfaces can free one B channel on each interface to carry other traffic.

Any hard failure causes a switchover to the backup D channel and currently connected calls remain connected. Backup D channel cannot be used for data transfer.


Note   On the Nortel dms100 switch, when a single D channel is shared, multiple PRI interfaces may be configured in a single trunk group. The additional use of alternate route indexing, which is a feature of the dms100 switch, provides a rotary from one trunk group to another. This enables the capability of building large trunk groups in a public switched network.

Restrictions

The following restrictions apply to this feature:


Table 1: ISDN Switch Types and Supported NFAS Types
Switch Type NFAS Type

Lucent 4ESS

Custom NFAS

Nortel DMS250

Custom NFAS

Nortel DMS100

Custom NFAS

Lucent 5ESS

Custom - Does not support NFAS

Lucent 5ESS

NI-2 NFAS

AGCS GTD5

NI-2 NFAS

Other Switch Types

NI-2 NFAS

Related Documents

Supported Platforms


Table 2: Cisco IOS Release and Platform Support for this Feature
Platform 12.1(5)XM 12.2(2)XB1 12.2(11)T

Cisco AS5800

X

Not supported

X

Cisco AS5850

Not supported

X

X

Determining Platform Support Through Cisco Feature Navigator

Cisco IOS software is packaged in feature sets that support specific platforms. To get updated information regarding platform support for this feature, access Cisco Feature Navigator. Cisco Feature Navigator dynamically updates the list of supported platforms as new platform support is added for the feature.

Cisco Feature Navigator is a web-based tool that enables you to determine which Cisco IOS software images support a specific set of features and which features are supported in a specific Cisco IOS image. You can search by feature or release. Under the release section, you can compare releases side by side to display both the features unique to each software release and the features in common.

To access Cisco Feature Navigator, you must have an account on Cisco.com. If you have forgotten or lost your account information, send a blank e-mail to cco-locksmith@cisco.com. An automatic check will verify that your e-mail address is registered with Cisco.com. If the check is successful, account details with a new random password will be e-mailed to you. Qualified users can establish an account on Cisco.com by following the directions at http://www.cisco.com/register .

Cisco Feature Navigator is updated regularly when major Cisco IOS software releases and technology releases occur. For the most current information, go to the Cisco Feature Navigator home page at the following URL:

http://www.cisco.com/go/fn

Availability of Cisco IOS Software Images

Platform support for particular Cisco IOS software releases is dependent on the availability of the software images for those platforms. Software images for some platforms may be deferred, delayed, or changed without prior notice. For updated information about platform support and availability of software images for each Cisco IOS software release, refer to the online release notes or, if supported, Cisco Feature Navigator.

Supported Standards, MIBs, and RFCs

Standards

None.

MIBs

To obtain lists of MIBs supported by platform and Cisco IOS release and to download MIB modules, go to the Cisco MIB web site on Cisco Connection Online (CCO) at http://www.cisco.com/public/sw-center/netmgmt/cmtk/mibs.shtml.

RFCs

None.

Prerequisites

The router's channelized T1 controllers must be configured for ISDN, as described in the "Configuring ISDN PRI" section of the "Configuring Channelized E1 and Channelized T1" chapter in the Cisco IOS 12.1 Release Dial Solutions Quick Configuration Guide.

Configuration Tasks

To configure NFAS with D channel backup, complete the following task:

Configuring NFAS on PRI Groups

This section documents tasks used to configure NFAS with D channel backup. When configuring NFAS, you use an extended version of the ISDN pri-group command to specify the following values for the associated channelized T1 controllers configured for ISDN:

Command Purpose

Step 1 

pri-grou
p timeslots 1-24 nfas_d 
primary nfas_int number 
nfas_group number 

Configures, on one channelized T1 controller, the NFAS primary D channel.

Step 2 

pri-grou
p timeslots 1-24 nfas_d 
backup nfas_int number 
nfas_group number 

Configures, on a different channelized T1 controller, the NFAS backup D channel to be used if the primary D channel fails.

Step 3 

pri-grou
p timeslots 1-24 nfas_d none 
nfas_int number nfas_group 
number 

Configures, on other channelized T1 controllers, a 24 B channel interface, if desired. (Optional)

For an example of configuring three T1 controllers for the NFAS primary D channel, the backup D channel, and 24 B channels, along with the DDR configuration for the PRI interface, see the "NFAS Primary and Backup D Channels Example" section.

When a backup NFAS D channel is configured and the primary NFAS D channel fails, rollover to the backup D channel is automatic and all connected calls stay connected.

If the primary NFAS D channel recovers, the backup NFAS D channel remains active and does not switch over again unless the backup NFAS D channel fails.

Configuring POTS dial peer for NFAS Voice

This section documents the configuration command for adding the NFAS primary controller to the POTS dial peer config. Dial peers are used by the IOS voice stack for handling calls going from PSTN to VoIP side or vice versa. The dial peer config for each NFAS controller should contain the primary of the NFAS group.

Commands Purpose

Step 1 

port controller:D

Adds a NFAS primary to the POTS dial peer.

Disabling a Channel or Interface

You can disable a specified channel or an entire PRI, thus taking it out of service or put it into one of the other states that is passed in to the switch. To disable a specific channel or PRI, complete one of the following tasks in interface configuration mode:

Commands Purpose

Step 1 

isdn 
service dsl number b_channel 
number state state-value 

Takes an individual B channel out of service or set it to a different state.

Step 2 

isdn service dsl number 
b_channel 0 state state-value

Sets the entire PRI to the specified state.

These are the supported state values:

Verifying POTS dial peer for NFAS Voice

#show dial-peer voice
VoiceOverIpPeer1
        information type = voice,
        tag = 1, destination-pattern = \Q',
        answer-address = \Q', preference=0,
        numbering Type = \Qunknown'
        group = 1, Admin state is up, Operation state is down,
        incoming called-number = \Q', connections/maximum = 0/unlimited,
        DTMF Relay = disabled,
        modem passthrough = system,
        huntstop = disabled,
        in bound application associated: DEFAULT
        out bound application associated: 
        permission :both
        incoming COR list:maximum capability
        outgoing COR list:minimum requirement
        type = voip, session-target = \Q',
        technology prefix: 
        settle-call = disabled
        ip precedence = 0, UDP checksum = disabled,
        session-protocol = cisco, session-transport = udp, req-qos = best-effor 
        acc-qos = best-effort, 
        fax rate = voice,   payload size =  20 bytes
        fax protocol = system
        fax NSF = 0xAD0051 (default)
        codec = g729r8,   payload size =  20 bytes,
        Expect factor = 0, Icpif = 20,
        Playout: Mode adaptive,
        Expect factor = 0, 
        Max Redirects = 1, Icpif = 20,signaling-type = cas,
        CLID Restrict = disabled
        VAD = enabled, Poor QOV Trap = disabled, 
        voice class perm tag = \Q'
        Connect Time = 0, Charged Units = 0,
        Successful Calls = 0, Failed Calls = 0,
        Accepted Calls = 0, Refused Calls = 0,
        Last Disconnect Cause is "",
        Last Disconnect Text is "",
        Last Setup Time = 0.

Monitoring and Maintaining NFAS Groups

Monitoring NFAS Groups

To monitor NFAS groups, complete the following task in EXEC mode:

Commands Purpose

Step 1 

show 
isdn nfas group number

Displays information about members of an NFAS group.

Monitoring ISDN Service

To display information about ISDN channel service states, complete the following task in EXEC mode:

Commands Purpose

Step 1 

show 
isdn service

Displays information about ISDN channels and the service states.

Configuration Examples

This section provides the following configuration examples:

NFAS Primary and Backup D Channels Example

The following example configures ISDN PRI and NFAS on three T1 controllers of a Cisco 7500 series router. The NFAS primary D channel is configured on the 1/0 controller, and the NFAS backup D channel is configured on the 1/1 controller. No NFAS D channel is configured on the 2/0 controller; it is configured for 24 B channels.

Once the NFAS primary D channel is configured, it is the only interface you see and have to configure; DDR configuration for the primary D channel—which is distributed to all B channels—is also included in this example.

version 12.1
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
!
hostname travis-nas-01
!
aaa new-model
aaa authentication login default local
aaa authentication login NO_AUTHENT none
aaa authorization exec default local if-authenticated 
aaa authorization exec NO_AUTHOR none 
aaa authorization commands 15 default local if-authenticated 
aaa authorization commands 15 NO_AUTHOR none 
aaa accounting exec default start-stop group tacacs+
aaa accounting exec NO_ACCOUNT none
aaa accounting commands 15 default stop-only group tacacs+
aaa accounting commands 15 NO_ACCOUNT none
enable secret 5 $1$LsoW$K/qBH9Ih2WstUxvazDgmY/
!         
username admin privilege 15 password 7 06455E365E471D1C17
username gmcmilla password 7 071824404D06140044
username krist privilege 15 password 7 0832454D01181118
!         
!         
!         
!         
call rsvp-sync
shelf-id 0 router-shelf
shelf-id 1 dial-shelf
!         
!         
!         
resource-pool disable
!         
modem-pool Default
 pool-range 1/2/0-1/2/143,1/3/0-1/3/143
!         
clock timezone CST -6
clock summer-time CST recurring
!         
!         
!         
!         
ip subnet-zero
ip domain-name cisco.com
ip name-server 172.22.53.210
ip name-server 171.69.2.133
ip name-server 171.69.2.132
ip name-server 171.69.11.48
!         
isdn switch-type primary-5ess
isdn voice-call-failure 0
!         
!         
!         
!         
!         
!         
!
controller T1 1/0/0
 framing esf
 linecode b8zs
 pri-group timeslots 1-24
 description PacBell 3241933
----
! 
interface Loopback0
 ip address 172.21.10.1 255.255.255.255
!         
interface FastEthernet0/0/0
 ip address 172.21.101.20 255.255.255.0
 half-duplex
!         
interface Serial1/0/0:23
 no ip address
 ip mroute-cache
 isdn switch-type primary-5ess
 isdn incoming-voice modem
 no cdp enable
!         
interface Group-Async0
 no ip address
 group-range 1/2/00 1/3/143
!         
router eigrp 1
 network 172.21.0.0
 no eigrp log-neighbor-changes
!         
ip classless
ip route 0.0.0.0 0.0.0.0 172.21.101.1

ip http server

ip http authentication aaa
!         
snmp-server engineID local 0000000902000030F2F51400
snmp-server community 5urf5h0p RO
snmp-server community 5crapmeta1 RW
snmp-server community SNMPv1 view v1default RO

POTS Dial-Peer Configuration Example

The following example shows the configuration of a POTS dial peer with the primary controller of an NFAS group:

dial-peer voice 35 pots
    incoming called-number 45... destination-pattern 35... direct-inward-dial port 1/0/0:D prefix 35

PRI Service State Example

The following example reenables the entire PRI after it previously was disabled:

isdn service dsl 0 b-channel 0 state 0
 

Command Reference

This section documents modified commands. All other commands used with this feature are documented in the Cisco IOS Release 11.3 T command reference publications.

show isdn nfas group

To display all the members of a specified NFAS group or all NFAS groups, use the show isdn nfas group command in privileged EXEC mode.

show isdn nfas group [id-number]

Syntax Description

id-number

(Optional) Identifier number in the range from 1 to 24 of a specific NFAS group.

Defaults

None.

Command Modes

Privileged EXEC.

Command History
Release Modification

11.3

This command was introduced.

12.1(5)XM

This command was integrated into Cisco IOS Release12.1(5)XM.

12.2(2)XB1

This command was implemented on the Cisco AS5850 platform.

12.2(11)T

This command was integrated into Cisco IOS Release 12.2(11)T and support was added for the Cisco AS5850 platform.

Examples

The following is an output example from the show isdn nfas group command:

Router# show isdn nfas group 0
 
         ISDN NFAS GROUP 0 ENTRIES:
 
         The primary D is Serial12/0:1:23.
         The NFAS member is Serial12/0:2:23.
         The NFAS member is Serial12/0:3:23.
         The NFAS member is Serial12/0:4:23.
         The NFAS member is Serial12/0:5:23.
         The NFAS member is Serial12/0:6:23.
         The NFAS member is Serial12/0:7:23.
         The NFAS member is Serial12/0:8:23.
         The NFAS member is Serial12/0:9:23.
 
         There are 9 total nfas members.
         There are 215 total available B channels.
         The primary D-channel is DSL 0 in state IN SERVICE
         There is currently no backup D configured.
         The current active layer 2 DSL is 0.
 

The following three examples show the D channel state changes when rollover occurs from the primary NFAS D channel to the backup D channel. The first example shows the output with the primary D channel in service and the backup D channel in standby.

Router# show isdn nfas group 0
ISDN NFAS GROUP 0 ENTRIES:
 
The primary D is Serial1/0:23.
The backup D is Serial1/1:23.
The NFAS member is Serial2/0:23.
 
There are 3 total nfas members.
There are 70 total available B channels.
The primary D-channel is DSL 0 in state IN SERVICE.
The backup D-channel is DSL 1 in state STANDBY.
The current active layer 2 DSL is 0.
 

The following example shows the output in the middle of rollover. The configured primary D channel is in maintenance busy state and the backup D channel is waiting.

Router# show isdn nfas group 0
ISDN NFAS GROUP 0 ENTRIES.
The primary D is Serial1/0:23.
The backup D is Serial1/1:23.
The NFAS member is Serial2/0:23.
 
There are 3 total nfas members.
There are 70 total available B channels.
The primary D-channel is DSL 0 in state MAINTENANCE BUSY.
The backup D-channel is DSL 1 in state WAIT.
The current active layer 2 DSL is 1.
 
 

Table 2 describes the fields in the output example.


Table 3: show isdn nfas group Field Descriptions
Field Description

The primary D is Serial1/0:23.

Identifies the primary D channel.

The backup D is Serial1/1:23.

Identifies the backup D channel.

The NFAS member is Serial2/0:23.

Identifies the NFAS group.

There are 3 total nfas members.

Number of member interfaces in the group.

There are 70 total available B channels.

Number of B channels in this NFAS group.

The primary D-channel is DSL 0 in state STANDBY.

Service state of the NFAS primary D channel; this D channel is in service.

The backup D-channel is DSL 1in state IN SERVICE.

Service state of the NFAS backup D channel; this D channel is in service. The states are In service, standby, out of service, maintenance, wait, initialized, and busy.

The current active layer 2 DSL is 1.

Digital subscriber loop (DSL) identifier assigned by the service provider. If both D channels are out of service, the value displayed in this line is -1.

Related Commands
Command Description

show isdn

Displays the information about memory, Layer 2 and Layer 3 timers, and the status of PRI channels.

show dial-peer voice

To display all the members of a specified NFAS group or all NFAS groups, use the show dial-peer voice command in privileged EXEC mode.

show dial-peer voice

Syntax Description

This command has no arguments or keywords.

Defaults

None

Command Modes

Privileged EXEC.

Command History
Release Modification

11.3(1)T

This command was introduced.

11.3(1)MA

The summary keyword was added for the Cisco MC3810 multiservice concentrator.

12.0(3)XG

This command was modified to support Voice over Frame Relay (VoFR) for the Cisco 2600 series and Cisco 3600 series routers.

12.0(4)T

Support was added for VoFR for the Cisco 7200 series routers.

12.1(3)T

This command was modified for Modem Passthrough over Voice over IP on the Cisco AS5300 universal access server.

12.1(5)XM

This command was introduced.

12.2(2)XB1

This command was implemented on the Cisco AS5850 platform.

12.2(11)T

This command was integrated into Cisco IOS Release 12.2(11)T and support was added for the Cisco AS5850 platform.

Examples

The following is an output example from the show command:

Router# show dial-peer voice 35
VoiceEncapPeer35
        information type = voice,
        tag = 35, destination-pattern = \Q35...',
        answer-address = \Q', preference=0,
        numbering Type = \Qunknown'
        group = 35, Admin state is up, Operation state is up,
        incoming called-number = \Q45...', connections/maximum = 0/unlimited,
        DTMF Relay = disabled,
        huntstop = disabled,
        in bound application associated: DEFAULT
        out bound application associated: 
        permission :both
        incoming COR list:maximum capability
        outgoing COR list:minimum requirement
        type = pots, prefix = \Q35',
        forward-digits default
        session-target = \Q', voice-port = \Q1/0/0:D',
        direct-inward-dial = enabled,
        digit_strip = enabled,
 
        register E.164 number with GK = TRUE
        Connect Time = 0, Charged Units = 0,
        Successful Calls = 0, Failed Calls = 0,
        Accepted Calls = 0, Refused Calls = 0,
        Last Disconnect Cause is "",
        Last Disconnect Text is "",
        Last Setup Time = 0.
 
 

Glossary

24 B channel interface—A PRI channel group configured to have no NFAS D channel; all its channels are B channels.

ISDN—Integrated Services Digital Network.

NFAS—Non-Facility Associated Signaling. An ISDN service that allows a single D channel to control multiple PRI interfaces. Use of a single D channel to control multiple PRI interfaces can free one B channel on each interface to carry other traffic.

NFAS group—A PRI channel group (the group of interfaces) under control of a single D channel. The channel group can include all the ISDN channels on multiple T1 controllers. Cisco IOS supports ten PRI interfaces in an NFAS group with a primary D channel and a backup D channel. Five NFAS groups are supported in a single chassis.

NFAS member—A PRI interface in an NFAS group. For example, an NFAS group might include serial interfaces 1/0:23, 1/1:23, and 2/0:23 if T1 controllers 1/0, 1/1, and 2/0 are configured for NFAS.

POTS—Plain old telephone service.

PRI—Primary Rate Interface.


hometocprevnextglossaryfeedbacksearchhelp
Posted: Thu Aug 22 09:58:20 PDT 2002
All contents are Copyright © 1992--2002 Cisco Systems, Inc. All rights reserved.
Important Notices and Privacy Statement.